European colleagues can't submit responses (DEADLINE)

  • 18 November 2022
  • 1 reply

Userlevel 1
Badge +1

We are receiving notices from European colleagues that their responses will not load when they hit submit. (error details and screenshot below)

We have a deadline this weekend to receive submissions (for conference presentations), and need to sort this out ASAP. 

We don’t know how far this problem extends, only that we know of it in Europe (successful submissions so far are from the US). Users have already tried reloading the form, using different browsers, clearing their cache, etc. (the instructions we received from a helpdesk ticket).

Anyone else have similar issues or know of possible solutions? We were planning to use this tool extensively for multiple conference needs but if this problem persists it will be of no use to us all.

Here are the errors:

I have tried to submit a proposal several hours ago and it still just says "Your response hasn't been sent yet. Well, this is embarrassing. Retrying in 14 seconds..." and then it reloads with the same message and counts down from 30. Thought it might be an issue with Chrome, so just tried via Firefox as well, and I'm getting the same message displayed there. I'll leave it running, in case it's an issue with typeform that can be resolved and will allow for submission somehow.

And a screenshot from another user:

Thank you for any help/advice!

1 reply

Userlevel 7
Badge +5

Hi @jshirk Could you share the URL of the form so we can test it? Thanks!