Feedback
Answered

Launch in Email Answer not Preselected


Userlevel 1

I am using the Launch in Email feature and embedding the code in a ConstantContact email. Everything seems to be working, including passing a parameter to a hidden field, but the user’s selected answer to the embedded first question (multiple choice) is not preselected in the form. This means that the user clicks an answer in the email, goes to the form, and then has to click the answer again in the form. There is branching logic based on this first answer if that is relevant.

icon

Best answer by kjblakeman 2 May 2022, 19:16

View original

6 replies

Userlevel 3
Badge +3

Hi @kjblakeman could you share your form url so that we can have a look? Thanks

Userlevel 1

https://6vyu5fr7uht.typeform.com/to/WKCWoqqb#id=xxxxx

However, in the email it looks like:

I had to manually change the parameter from #[[custom.import]] to &[[custom.import]] for the parameter to get into the hidden field.

Userlevel 1

So it appears to work here. Testing from Outlook and Gmail receiving the survey, however, did not result in a preselected answer. 

Userlevel 1

After many tests across a variety of operating systems and browsers, I found that either I can get ConstantContact to replace the variable with a value by changing #id=[[custom.import]] to &id=[[custom.import]] OR I can have the form take the answer from the email. If I make the change to get the variable to populate in ConstantContact, the form will not accept the answer selected in the email.

Userlevel 3
Badge +3

Hi @kjblakeman  Sorry for the late reply, glad it’s working. 

I was testing your form and it worked fine for me (see attached video). Some mail client might not work as expected and unfortunately we cannot predict that as it depends on the email client.

Let me know if you still have issues with email, I will be glad to help.

 

Userlevel 1

Thanks @Antonio , but I never did get it to actually work. I can either have the form use the parameter to pass a variable (by changing the code for the hidden field to use & rather than #) OR I can have the first question work as advertised (by not adjusting the auto-generated code). If I change the code for the hidden field, the first answer does not work. That was our solution because we had to proceed, but it is less than ideal. I assume it would work as intended in MailChimp.

Reply