Question

Branching and Calculations' multiply logic is broken

  • 22 February 2021
  • 16 replies
  • 133 views

Userlevel 2

I’ve been trying to get this right, but the editor crashes every single time I try to add multiply logic command to interact with “numbers” question result. I’ve attached a video. What I want to achieve is quite simple. You first choose the most relevant picture (that has specific variable added), then you choose number (metric) and now it should calculate a variable multiplied by number answer.

 

 


16 replies

Userlevel 1

Same here, also with the ‘add’ logic

Userlevel 2

Yeah, I noticed the same. 😩I’m creating this for a client and this bug seems to mess my plans big time.

Userlevel 1

Exactly the same ahah, needed to finish my integration for tomorrow but I’ll wait 

Userlevel 7
Badge

Hi @Mikael Thanks for sharing that video and wow, that’s strange. What browser are you using? I can’t quite tell from the icon. 

For everyone else, if you wouldn’t mind also sharing what browser you’re on, that would be handy!

Userlevel 2

@Liz My browser is Chrome. 

Userlevel 2

@RémiZ I know right! 😞 I am also having a tight schedule, let’s hope they fix it soon.

Userlevel 2

@Liz I’ve also tried it with Safari, and it has the same bug. 

Userlevel 6
Badge

Hey @Mikael and @RémiZ. Thanks so much for reporting this! 

 

I was able to reproduce the issue on my side and I've escalated this to the relevant team. I will keep you posted in this thread, and I will let you know as soon as I hear from them. Hopefully, it won't take long.

Userlevel 2

@Mariana Thank you so much, that feature is super important to us. :) 

Userlevel 6
Badge

Hello everyone. 👋🏻

 

I'd like to share with you that this issue was escalated with high priority to our devs. Our product team is looking into this and investigating the root cause. Thanks for your patience in the meantime!

Userlevel 2

@Mariana Thanks for letting us know :)

Userlevel 6
Badge

Hi there!

 

A quick update about this temporary glitch: We're still investigating it but it seems the issue is not about logic calculations, but about the title of the number question.

 

For example, if the name is short e.g. “NUMBER” - it works fine. 

However, if the name is "“Aidan pituus. Syötä ainoastaan täysiä metrejä, esim. ei 3,5 vaan 4" - then there is a non stop flickering till site becomes unresponsive.

 

We understand this is not ideal, but a workaround while we have this pending to be solved, would be changing the title of the question (probably removing any special character you're using).

 

Can you try that and let me know if it helps? =)

Userlevel 2

Okay, thanks for the workaround. Right now the most important thing is to get it to work again, so if the title needs to be shorter, that’s okay. :)

Userlevel 6
Badge

Woohoo! Who wants good news? 🥳

 

A fix has now been released! We've tested it with some forms and they worked just fine.

 

Let us know if yours are working properly too! It should work even if you're using long titles now. 🤩

Userlevel 1

Yeah it works awesome ! Thank you 

Userlevel 6
Badge

Yay! That's great to hear =)

Reply