Feedback
Answered

Price Variable Not Showing

  • 10 August 2021
  • 18 replies
  • 216 views

Hi, I created a form and apply logic and wondering why I don’t see the PRICE variable. I can only see the QUIZ variable. I am sure that the form created is not  a Quiz type. 

I can create a new variable as a solution though. 

 

icon

Best answer by john.desborough 11 August 2021, 13:00

View original

18 replies

Userlevel 7
Badge +5

Hi @Grant512 Welcome to the community! In order to see the price variable, you’ll need to add the payment question to your form. 

I hope this helps! Let me know if you’re still not seeing the variable after adding the payment question. 

wow that’s tricky. But I do not need client to pay anything yet. This is just a quote for them to decide. 

Userlevel 7
Badge +6

@Grant512 - this form another user

when i have been putting info together for clients, like a quote, i create a variable (I call it v_price) which i can populate in the same way as price from the calculations and logic rules. 

I will also do that sometimes in a payment question as well so that i can show the client a subtotal before hitting the payment page - to minimize any errors that make it directly to cc. 

 

just a thought

des

Thank you all.

Badge

Hello! I’ve added a payment question but still can’t see the price variable. Is that because I haven’t connected a Stripe account yet, perhaps? Thanks!

Userlevel 7
Badge +5

Hi @FrankElixx Have you clicked the publish button on your form? Sometimes this helps solve the issue. 

If you have, you should see the price variable by going to Logic → Advanced → Variables. 

If you’re not seeing it there, would you mind sending a screenshot of your form so we can take a closer look? :grinning:

Badge

Hello,

So @price did appear the next time I logged in (and upgraded account from Free to Basic - may go Business but undecided). But now it’s disappeared again, during the same session, and @price has disappeared from the logic I just set up… very odd! Still in the variables section.

I don’t want to publish yet as it’s unfinished. Any suggestions?

 

Userlevel 7
Badge +5

Hi @FrankElixx Huh, that is odd. I would suggest publishing the form to see if that helps first solve the issue, just in case the pricing field isn’t registering in the logic map. 

Badge

Thanks for the advice Liz - so I presume if I publish can I still edit the form afterwards?

 

Userlevel 7
Badge +5

Oh yes, of course, @FrankElixx ! You can certainly keep editing after you’ve published the form. 

Badge

This worked! Thank you!

Userlevel 7
Badge +5

Yas!! Glad to hear, @FrankElixx !! Let us know if we can help with anything else!

@Liz 

Hello ! 

Well, I have exaclty the same problem as @FrankElixx, i.e. that the variable @price is shown in the default variables of my form but it does’nt show in the Branching and Calculation.
However publishing the form has not helped me
Do you have any other solution ? 
 

Userlevel 7
Badge +6

@leonkratos - welcome to the community. 

 

can you show a screen shot or recording of how you have set up your logic? that will help us troubleshoot

cheers

 

des

@john.desborough - Thank you !

Well, I wanted to send you a screenshot right now and the variable @price suddently appeared in my Branchin and Calculations window, so problem resolved ! I don’t know why though but it works, that’s the most important.

Thanks for your quick answer

Have a great day :)

 

Userlevel 7
Badge +5

Glad to hear it resolved itself, @leonkratos ! :joy: Let us know if we can help with anything else. 

I had the same issue, the @price tag still wasn’t showing. A simple solution though, refresh the entire page and hey presto is showed up.

Userlevel 7
Badge +5

@robinmwaite Woot! Glad it was simple as a page refresh! 

 

Reply