Feedback
Solved

Start Button on Mobile


Userlevel 1

I noticed on mobile there is a “start” button with the title of the form. How do we set our forms to simply load like on desktop?

icon

Best answer by Liz 17 April 2021, 00:42

Hi @adopttheweb thanks for stopping by! The start button appears on mobile when you don’t have a welcome screen. You can learn more about this here

To skip the Start button on embedded forms when viewing on mobile, add ?typeform-welcome=0 after the URL in the embed code. Your typeform must have a Welcome Screen for this to work.

I hope this helps! :smile:

View original

40 replies

Userlevel 7
Badge +5

Hi @adopttheweb thanks for stopping by! The start button appears on mobile when you don’t have a welcome screen. You can learn more about this here

To skip the Start button on embedded forms when viewing on mobile, add ?typeform-welcome=0 after the URL in the embed code. Your typeform must have a Welcome Screen for this to work.

I hope this helps! :smile:

Userlevel 1

Perfect! Hopefully this shows up in a search for the next guy looking for how to remove the start button of their typeform on mobile :)

Userlevel 7
Badge +5

Hope so too, @adopttheweb ! Let me know if you have any other questions. :grinning:

Hi @Liz - I have tried your solution there - I may be missing something but it’s not working…. there are two URLs in the embed code… is this where it should be? 

 

<div class="typeform-widget" data-url="https://form.typeform.com/to/XhJ7isgl?typeform-medium=embed-snippet" ?typeform-welcome=0 style="width: 100%; height: 500px;"></div> <script> (function() { var qs,js,q,s,d=document, gi=d.getElementById, ce=d.createElement, gt=d.getElementsByTagName, id="typef_orm", b="https://embed.typeform.com/"; if(!gi.call(d,id)) { js=ce.call(d,"script"); js.id=id; js.src=b+"embed.js"; q=gt.call(d,"script")[0]; q.parentNode.insertBefore(js,q) } })() </script>

 

Thank you!

Userlevel 7
Badge +5

Hi @calliefit You’ll want to place the ?typeform-welcome piece right after the URL within the “ like this: 

 

<div class="typeform-widget" data-url="https://form.typeform.com/to/XhJ7isgl?typeform-medium=embed-snippet?typeform-welcome=0"

 

Let me know if that doesn’t work! 

Badge

Hello!

Unfortunately this is not working for me. What am I doing wrong?

 

<div class="typeform-widget" data-url="https://form.typeform.com/to/raY8eZPD?typeform-medium=embed-snippet?typeform-welcome=0" data-transparency="50" data-hide-headers="true" style="width: 100%; height: 500px;"></div> <script> (function() { var qs,js,q,s,d=document, gi=d.getElementById, ce=d.createElement, gt=d.getElementsByTagName, id="typef_orm", b="https://embed.typeform.com/"; if(!gi.call(d,id)) { js=ce.call(d,"script"); js.id=id; js.src=b+"embed.js"; q=gt.call(d,"script")[0]; q.parentNode.insertBefore(js,q) } })() </script>

 

Is there a way to skip the welcome screen on desktop too?

 

Thanks,

Sylvain

Userlevel 7
Badge +6

@sylvainww - welcome to the community from another user

to skip welcome screen on the desktop, remove it from your typeform. If you don’t have one, it won’t show. 

 

des

Badge

Thanks @john.desborough 

My issue is that if I do that, then on mobile I can not skip the “start” button. 

Basically I just want users to see the first question directly, whether they are on mobile or desktop.

Userlevel 7
Badge +5

Hi @sylvainww Do you mind sharing the URL where you have the form embedded? I can then take a peek at what’s going on. :grinning:

Badge

Hi @Liz - here is the link https://growthgems.co/join-growth-gems-typeform

Thanks!

Userlevel 7
Badge +5

Thanks, @sylvainww ! It looks like the welcome screen I’m seeing on mobile is one that you have on the form currently. Would you mind removing the welcome screen in the form builder (if you’re not looking to use one)? 

 

Badge

@Liz sure thing. Just made the change.

Userlevel 7
Badge +5

Hi @sylvainww Thank you! I see that didn’t work either. :( Do you mind adding the welcome screen back? Apologies for all the back and forth!

Badge

No worries @Liz! Just added it back.

Thanks so much for helping.

 

 

Hi there,

 

I’m facing a similar issue trying to hide the welcome screen of any sort on both desktop and mobile.

Tried the above and none work as expected.

Could you please explain what is the final fix for this?

 

Thanks

Userlevel 7
Badge +5

Hi @flo Thanks for stopping by! If you’ve added the welcome screen and the parameter at the end of the URL and it still isn’t working, would you mind sharing the URL where you have the form embedded? Thanks!

Badge

Hi there,

 

I’m facing a similar issue trying to hide the welcome screen of any sort on both desktop and mobile.

Tried the above and none work as expected.

Could you please explain what is the final fix for this?

 

Thanks

Hi @flo! Unfortunately it seems that there isn’t a way to do that, and I haven’t heard back. So I decided to just keep a welcome screen on both mobile and desktop, and try to make the most out of it.

If you do find a solution, please post here :pray:

 

Userlevel 7
Badge +5

Hi @sylvainww If you haven’t already contacted them, our technical support team can take a further look into this to see why the provided options aren’t working. They can be contacted from your account email here

Hopefully that helps a bit! 

Hi there,

On desktop, there is no “start” page for my typeform. People just answer the first question and continue. On mobile however, the same quiz has a start button for the quiz. When I click it, it opens up a full page version of it on mobile. How can I remove the start button and just have the first question show? The quiz is currently embedded on my landing page.

Userlevel 7
Badge +5

Hi @prasadmahes I added your post here where we have the answer. Let us know if you have any other questions! 

Hi there, I am just reading this thread. What I don’t understand is how can I skip the start button without having a welcome screen on mobile? I want neither a welcome screen or a start button. I just want people to engage with the quiz!

 

here is where it is embedded: 

www.cannabisclinic.co.nz 

This is the embed code 

<div class="typeform-widget" data-url="https://form.typeform.com/to/CdYhGTDQ?typeform-medium=embed-snippet" style="width: 100%; height: 500px;"></div> <script> (function() { var qs,js,q,s,d=document, gi=d.getElementById, ce=d.createElement, gt=d.getElementsByTagName, id="typef_orm", b="https://embed.typeform.com/"; if(!gi.call(d,id)) { js=ce.call(d,"script"); js.id=id; js.src=b+"embed.js"; q=gt.call(d,"script")[0]; q.parentNode.insertBefore(js,q) } })() </script>

 

Many thanks 

Waseem

Hi! Liz!

I tried adding the code and it did not work. I decided the rename the form for now so it at least makes sense to clients on mobile. When the support team finds a solution to why the code isn’t working. Please reach out or add it to this thread. I’d appreciate it a lot. 

 

Thanks,

Andrew 

 

 

Userlevel 7
Badge +6

@Andrew Ulloa - this is from another user. 

have you submitted a help ticket on this issue to the support team? so that you have two vectors for the answer/updates? if not, use this link

@Liz 

 

Hi, how can I turn off the cover page on mobile, if I am using the createWidget function to embed my survey? ie. how do I set the option for typeform-welcome to 0? 

Thanks

 

window.tf.createWidget(formId, {

                    container: document.getElementById("wrapper"),

                    hidden: {

                        userId: receivedEvent.userId,

                        visitorId: receivedEvent.visitorId

                    }

}

Userlevel 7
Badge +5

@Liz

 

Hi, how can I turn off the cover page on mobile, if I am using the createWidget function to embed my survey? ie. how do I set the option for typeform-welcome to 0? 

Thanks

 

window.tf.createWidget(formId, {

                    container: document.getElementById("wrapper"),

                    hidden: {

                        userId: receivedEvent.userId,

                        visitorId: receivedEvent.visitorId

                    }

}

@mathio do you happen to know if this is an option using the Embed SDK? :grin:

Reply