Feedback
Answered

Airtable integration won't save (unhelpful error message)

  • 3 August 2022
  • 4 replies
  • 28 views

Userlevel 1
Badge

I have completed all the steps of the typeform → airtable integration, but when I try to save the integration I get the below error saying “We couldn’t save your integration. Please try saving again.” I have tried clicking ‘Retry’ multiple times and even started over and rebuilt the mappings, but I end up with the same error. How do I troubleshoot this?

 

 

icon

Best answer by jstrauss 6 August 2022, 01:55

View original

4 replies

Userlevel 1
Badge

I have tried some different integration setups and I only get this error when trying to map a typeform hidden field to an airtable field. The integration works fine if I just use typeform questions with no typeform hidden fields. And it always fails to save with the above error when I use a typeform hidden field even with different typeform forms, hidden fields, airtable fields, and airtable bases. This appears to be a regression, because I have a couple of other typeform forms with active airtable integrations using typeform hidden fields.

Userlevel 7
Badge +5

Hello @jstrauss! Welcome to our Community! 😊

There's a bug when you try to use hidden fields with the Airtable integration. Our team is working on it. I suggest you also follow this thread for updates: 

I'll keep you posted here as well. Have a nice day!

Userlevel 1
Badge

Thanks for the update and the pointer Gabi! Is there any ETA currently on the bug fix that you can share (do you know if it’s currently assigned internally or still in the backlog/icebox)? Our app’s signup flow depends on a typeform/Airtable integration with a hidden field, so I’m trying to figure out how big of a workaround I’ve got to come up with for how long.

Userlevel 1
Badge

This bug was fixed by the Typeform team.

Reply