Feedback
Question

Google Analytics and Google Ads not working anymore with new typeform embeding code

  • 26 January 2023
  • 5 replies
  • 51 views

Userlevel 1

Hey we have multiple typeforms embeded in our website and after we updated all of them tot he latest typeform code embeding code in 6th of Decemeber. The problem is that Google analytics stopped recording our conversions after 22 of December. We tried the following things to fix the problem: 

 

We have a script in the page which copies the utm params and stores them in a cookie and every time we render the typeform we send the utm params to typeform as hidden fields.

Our ending screens are always redirect screens to a page in our website. We managed to fix the typeform conversions in google analytics by adding in the redirect screen the utm params from the hidden fields but this just fixes the Google analytics problem if we import our data in Google Ads then google ads doesn’t see any conversion, and we are wandering what we should do to fix it ? Should we forward also the gclid from the url to typeform and then put it as a query parameter in the redirect screen ?

 

One thing to mention is that until 22 of December 2022 our conversions worked without problems without doing the magic thing in the redirect url with Google Analytics and then importing data from Google Analytics to Google Ads always worked.

This is our embeding code until 6 of Decemeber for typeform:

<div class="typeform-widget" data-url="[https://form.typeform.com/to/O72L8Nlf?typeform-welcome=0&utm_source=xxxxx&utm_medium=xxxxx&utm_campaign=xxxxx&utm_term=xxxxx&utm_content=xxxxx#language=de-CH&industry_sectors=INDUSTRY_SECTOR_CARPORT&active_campaign_tag_id=536&register_source=typeform-carport-lead&typeform-medium=embed-snippet](https://form.typeform.com/to/O72L8Nlf?typeform-welcome=0&utm_source=xxxxx&utm_medium=xxxxx&utm_campaign=xxxxx&utm_term=xxxxx&utm_content=xxxxx#language=de-CH&industry_sectors=INDUSTRY_SECTOR_CARPORT&active_campaign_tag_id=536&register_source=typeform-carport-lead&typeform-medium=embed-snippet)" data-transferable-url-parameters="utm_source, utm_medium, utm_campaign, utm_content" style="width: 100%; height: 750px;"></div> <script> (function() { var qs,js,q,s,d=document, gi=d.getElementById, ce=d.createElement, gt=d.getElementsByTagName, id="typef_orm", b="[https://embed.typeform.com/](https://embed.typeform.com/)"; if(!gi.call(d,id)) { js=ce.call(d,"script"); js.id=id; js.src=b+"embed.js"; q=gt.call(d,"script")[0]; q.parentNode.insertBefore(js,q) } })() </script>

This is our embeding code after 6 of December 

<div data-tf-widget="O72L8Nlf" data-tf-inline-on-mobile data-tf-medium="snippet" data-tf-hidden="utm_source=xxxxx,utm_medium=xxxxx,utm_campaign=xxxxx,utm_term=xxxxx,utm_content=xxxxx,language=de-CH,industry_sectors=INDUSTRY_SECTOR_CARPORT,active_campaign_tag_id=536,register_source=typeform-carport-lead,reference_url=xxxxx,session_tracking_url=xxxxx" style="width:100%;height:100vh;"></div><script src="[//embed.typeform.com/next/embed.js](notion://embed.typeform.com/next/embed.js)"></script>

I have to mention that we have a script which goes over the urm params for typeforms and updates them from our cookies.

Did you guys change how the redirect screen behaves somehow ? Before the conversion in Google analytics and Google Ads just worked and after 22 of December we are not registering any conversions in Google Analytics.

Can you help us out or point in the right direction for our problem. ?

 


5 replies

Userlevel 7
Badge +5

Hi @Houzy Could you share the URL where you have the form embedded? Thanks!

Userlevel 1

@Liz Thanks for response here is a google add link to a typeform which we have embeded

https://www.houzy.ch/handwerker/baumeister?utm_source=Google&utm_medium=cpc&utm_campaign=DE_GSN_Offerflow-Builder_Automated&utm_content=Baumeister&gclid=CjwKCAiA5sieBhBnEiwAR9oh2ieHbRTAMKqt8TMDa_qTstawLRKYeqrQhXSxUrcpBlDU15l3CZLgChoCTHIQAvD_BwE

Please use the a name and an email which contains `test` so that our team knows that this is not a real offer :) 

Userlevel 1

I retested the flows to be sure that what I’m saying is right and it seems reverting to the old embeding code doesn’t fix the conversion issue. The weird thing is that we get conversions in Google Analytics but in Google Ads nothing. With both new typeform embedding code and old typeform embedding code. Any ideas pointing us to the right direction ?

Userlevel 7
Badge +5

Hi @Houzy Thank you for sending that over! I’m seeing a bunch of custom code pointed to our Typeform. Could you remove that and only add the code we provide to see if that helps with the issue? 

Userlevel 7
Badge +5

Hey @Houzy were you able to try Liz’s suggestion yet? Let us know if it worked or if you need any more help! 😊

Reply