Question

Hidden fields not working (Airtable -> Zapier -> Typeform)

  • 22 March 2021
  • 5 replies
  • 571 views

Hey everyone,

 

I need some help getting hidden fields to work, particularly when used across Zapier and Airtable. I’m using the new Typeform builder.

 

I’ve created a feedback survey with which includes hidden fields to recall information about the customer’s booking. As I want to send the survey link at scale, I’ll be automating the process and creating the email within Zapier. All the customer information is stored in Airtable, so I’ve applied a formula to populate a prefilled Typeform URL. Everything looks good in Airtable and Zapier, but when I click the link in the email, it doesn’t pull in the hidden fields.

 

I’ve completed this task before, but it was linking to a Typeform created with the classic builder. Is there something I’m missing?


5 replies

Userlevel 7
Badge +5

Hi Apollo,

Are the hidden fields defined on your form?
Hidden fields are now under Logic → Advanced → Hidden fields.

Also what is the form of the URL?
it should be
https://form.typeform.com/to/{form_id}#email=kiki@lol.com&order_id=1234

note the # that replaced the ?

 

Hey @picsoung, I’ve defined the hidden fields in Typeform. I have Company, Agent, Address and Auctioneer. All seem to be added correctly here. Here’s the URL:

https://auctionbookings.typeform.com/to/A3CpuKRY#company=xxxxx&agent=xxxxx&address=xxxxx&auctioneer=xxxxx

 

To create unique emails for thousands of customers following the above URL format, I’ve used a formula within Airtable to populate this. The formula I’m using is shown below. 

 

"https://auctionbookings.typeform.com/to/A3CpuKRY#"& ENCODE_URL_COMPONENT('Agent')& '=' & ENCODE_URL_COMPONENT({Agent})& '&' &ENCODE_URL_COMPONENT('name')& '=' & ENCODE_URL_COMPONENT({Agent})& '&' &ENCODE_URL_COMPONENT('Address')& '=' & ENCODE_URL_COMPONENT({Address})& '&' &ENCODE_URL_COMPONENT('Company')& '=' & ENCODE_URL_COMPONENT({Company})& '&' &ENCODE_URL_COMPONENT('Salutation')& '=' & ENCODE_URL_COMPONENT({Salutation})& '&' &ENCODE_URL_COMPONENT('Auctioneer')& '=' & ENCODE_URL_COMPONENT({Auctioneer})

 

Here’s an example of the URL the formula created. A lot of the information is just placeholder whilst I run some tests, but regardless of that, it should pull this information into the Typeform, however it doesn’t.

 

https://auctionbookings.typeform.com/to/A3CpuKRY#Agent=Caitlyn%20Irwin&name=Caitlyn%20Irwin&Address=123%20Test%20Road%2C%20Example&Company=Apollo%20Auctions&Salutation=Caitlyn&Auctioneer=Caitlyn%20Irwin

 

I have this formula setup for a different Zap which links to a different Typeform and it works correctly. The only difference I’ve found is that the Typeform uses the classic builder. I’ve tried copying and pasting the formula used for that Zap and then updating the Typeform link part, but that isn’t working either.

 

Do you have any further suggestions based on the above?

Seeing a similar issue with typeform → zapier → slack

Hidden fields that are successfully passing from the url into the typeform are seen as ‘xxxxx’ in zapier?

Seeing a similar issue with typeform → zapier → slack

Hidden fields that are successfully passing from the url into the typeform are seen as ‘xxxxx’ in zapier?


Nevermind - it looks like a sales rep was duplicating and sending the typeform to prospects without the hiddenfield information!

Userlevel 7
Badge +5

Glad to hear it was an easy fix, @edoc34 ! Let us know if you need help with anything else. 

Reply