Feedback
Answered

Disable VideoAsk Response autoplay

  • 22 September 2022
  • 3 replies
  • 15 views

Userlevel 1

We’re embedding response videos into our app and our users have shared that the autoplay functionality is distracting. To be clear, the audio is not playing, but the video plays without sounds as soon as you load the page. We tried removing the autoplay attribute from the iframe code, and when we did that we occasionally see an issue with the play button not appearing at all, so I’m wondering if there’s a better way to display the video thumbnail instead of the video itself until the user clicks on the video.

Example embed:

<iframe
title="Shared video"
src={url}
allow="encrypted-media *; fullscreen *;"
className="w-full rounded-md aspect-video"
/>

Example page: https://app.dev.learnexusdev.com/talent-profile/5146

Loom demonstrating the missing play button: 

 

icon

Best answer by Grace 23 September 2022, 09:16

View original

3 replies

Userlevel 7
Badge +5

Hey @Dominic thanks for stopping by!

If you head to Advanced Settings in the builder of your videoask you should find the Pause auto-play toggle which you can switch on if you don’t want the video playing automatically.

 

 

Hopefully that resolves it, but let me know if you have any other questions 😊

Userlevel 1

Thanks, Grace. Does that apply to the responses as well or just the prompt/question?

Userlevel 7
Badge +5

Hey @Dominic I believe it will only work on the videoask itself, I think if you’re embedding responses it can take a bit of fiddling to get a ?pauseautoplay parameter to work 😅

Reply