embedded Typeform not loading! help!

  • 10 February 2021
  • 8 replies

Userlevel 1

If you access this page, you’ll notice that the typeform doesn’t load on first pass, only when you refresh the page. Can someone help?


Best answer by Liz 10 February 2021, 20:27

View original

8 replies

Userlevel 1

actually, it’s only a problem when you access that page from the top-right button on the home page

Userlevel 7
Badge +5

Hi @michael . Thanks for stopping by! :) 

When typeforms are embedded on Squarespace websites, they need to be connected to other pages on the site using the full URL instead of the short URL provided by Squarespace.

For example, when connecting the pages together on Squarespace like this:

Example 1. /registration

You will instead want to use the full url like this:

Example 2.

This is because the typeform will activate once the page is fully loaded. In order for the page to load fully and thus show the typeform, you'll need to connect the pages together using the full URL.

Let us know if that doesn’t solve the issue!

@Liz Squarespace does not allow you to enter the full URL in the menu system.  Is there another solution?  I just implemented the form on 30 pages before I realized this was an issue.

Edit: You can add absolute links to the menu with some exceptions.  However, Typeform still does not load each time.  Wondering if there is another solution?


Userlevel 7
Badge +5

Hi @SOLIUS Do you receive an error message when trying to implement the full URL? Any screenshots you can provide would be helpful. 

Hi @Liz Thank you for your help! 

No error, it is just the way the Squarespace CMS builds the menu - by default, using relative links (which it won’t let you edit).  There is a workaround that allows absolute links for subpages in a dropdown menu.  I tried that first and it didn’t help much.

Then I tried disabling Ajax on the site, which I think is the real issue, with the hope that the site will reload each page (which may increase page load time...). 

However, at this point, between the browser cache and Squarespace cache, I don’t trust what I am seeing rendered so I am going to give the site a rest for day, empty my caches, and go back to it.

I see the most issue with the script running in main content area of the website.  I moved my subscription form down to the footer for now.  I think the footer caches and keeps the script running sometimes?  In any case, the form seems to work ok down there, however, I have a number of forms I would like to build in the main content area.

This is the site with the form in footer

Userlevel 7
Badge +5

Hi @SOLIUS Thanks for sending the URL! When I clicked the URL, the form loaded for me on the first try, so I can confirm the footer works!

Do you mind placing the form on a test page so I can see what’s happening when it loads into the main content area? (Or doesn’t load, in this case.)

Userlevel 7
Badge +5

Hey @SOLIUS! I have tested over here and the footer works for me as well, on the first try! 😊

Thank you @Gabi Amaral @Liz 

I created a test page here, with a relative link and absolute, link to a Typeform embedded in my main content area.  Both links seem to work, the form loads as it should.  If I were to hazard a guess at this point, I would think turning off Ajax did the trick, so the content loads each time.  However, ideally, I would be able to use Ajax to potentially decrease page load times.  Do you have any tips on getting a script to run on an Ajax loaded page where the whole page might not load each time?

Here is the test link: