Feedback
Answered

Meta preview changes (saved) not being replicated into post (linkedin)


Userlevel 7
Badge +6

Morning - trying to share a typeform into LinkedIn and have updated the Meta Preview as show in the image below: 

but what shows up when i copy and share the link into Linkedin: 

As you can see there is something that is not getting picked up in the meta preview, even after i have saved the meta preview… 

 

is there something wonky here or have i missed a step?? 

 

 

icon

Best answer by Mariana 1 February 2021, 14:23

View original

18 replies

Badge +5

Hey Des. Happy Monday!

Can you share the link of your typeform with me, pls?

Userlevel 7
Badge +6

@Gabriel - sent you direct message

Userlevel 7
Badge +5

Hello Des. Hope your Monday is going well 😄

 

You have likely set this up correctly in your Typeform account, but sometimes there can be a delay for the social media sites to catch/update the latest meta description from a form. Luckily, most of them offer a way to manually retrieve the latest info, by pasting in the URL of the form into their Post/Sharing inspector. You can find the Linkedin inspector here: Linkedin post-inspector

 

You have probably done that, but it is worth to mention that you'll also need to ensure the latest changes to the typeform have been 'Published' by pressing the button in the top right-hand corner of your Create panel. 😊

 

Does it give you the help you need? Let me know how it goes! 

Userlevel 7
Badge +6

Hello Des. Hope your Monday is going well 😄

 

You have likely set this up correctly in your Typeform account, but sometimes there can be a delay for the social media sites to catch/update the latest meta description from a form. Luckily, most of them offer a way to manually retrieve the latest info, by pasting in the URL of the form into their Post/Sharing inspector. You can find the Linkedin inspector here: Linkedin post-inspector

 

You have probably done that, but it is worth to mention that you'll also need to ensure the latest changes to the typeform have been 'Published' by pressing the button in the top right-hand corner of your Create panel. 😊

 

Does it give you the help you need? Let me know how it goes! 

@Mariana - thanks for the heads up on the delay factor. (Yes the typeform had been published and there were no changes made other than to the meta preview. I had even tested in the post-inspector at Linkedin as well, same results as above). I will wait till the top of the hour and check on LinkedIn to see if things have changed. 

i will note that even after i had made changes in the meta preview panel to change the title, and save the changed title, it reverted back to the previous version. it has been changed again and i will see if it reverts again. 

cheers

 

Badge +5

 

Looks like #Twitter is already showing the right information? Don’t worry, I didn’t post it :sweat_smile:

Userlevel 7
Badge +6

sweet.. that at least is good news @Gabriel . 

 

thanks for checking.. 

 

Userlevel 7
Badge +6

@Gabriel @Mariana - one of the things that I notice in the meta preview and in the ‘preview’ image shown by the LinkedIn post inspector and on the posts directly to LinkedIn, is that the meta title seems to default to the ‘name of the typeform’  - ie DQ-Root Cause, regardless of the edit made in the preview meta title field. When I change the name of the form and make it longer (Data Quality - Root Causes) that becomes more descriptive in the meta title. 

Just a thought that might make some sense for other curmudgeons like me to have this tidbit presented during the typeform naming process (if not seen to be be too advanced a topic for creating the form)

Maybe add a little bit into the ?info marker that the current title is set to the name of the typeform by default. 

just a thought 

Userlevel 7
Badge +5

Hey @john.desborough. Thanks for sharing this great feedback! I'll pass it on to our Product team and I'll be back to you when I hear from them. 😊

 

In the meantime, can you confirm if your Linkedin post is now updated with the proper image? Did it work? Looking forward to hearing good news! 

Userlevel 7
Badge +6

@Mariana - it finally worked.. 

Thank you and @Gabriel for your help on this.. 

here’s the live linkedin post.

(let me know what you think, if you check it out.. lol)

gracias!

 

Userlevel 7
Badge +5

Woohoo! That's great to hear, Des. 

 

For future reference, here you can also find the inspector link for other social media platforms:
📌 Facebook/WhatsApp debug tool

📌 Twitter Validator

 

And by the way, your post looks great! 

 

Userlevel 7
Badge +6

@Mariana - thank you for your help and your kind words.. 

 

cheers

Userlevel 7
Badge +5

To add to @Mariana’s list:
Linkedin Post Inspector
iframely generic debugger

Userlevel 7
Badge +6

thank you @picsoung 

Userlevel 7
Badge +6

coming back to the meta preview - is there a way to disable the image ie no image at all, or is this a requirement for a meta preview?? 

maybe it’s just the lack of a 3rd cup of coffee speaking on a friday morning, but just checking on this cuz i cannot seem to find the optimal size of image for the meta preview and was thinking of taking scissors to it but cannot seem to do so.. lol

 

cheers and TIA

Userlevel 7
Badge +5

Hi @john.desborough Ha! Gotta get another cup of coffee in! I’m not aware of the ability to remove the image in the LinkedIn preview, and this post here seems to confirm this, but possibly @picsoung knows a workaround I don’t know of.

Userlevel 7
Badge +6

Hi @john.desborough Ha! Gotta get another cup of coffee in! I’m not aware of the ability to remove the image in the LinkedIn preview, and this post here seems to confirm this, but possibly @picsoung knows a workaround I don’t know of.

Cup 4+ now.. and i see sounds and hear colours… a great way to hit Friday afternoon

more in the Typeform functilonality is what i was asking. Prior to posting the link to the social media ..

is it possible to remove the image (other than putting in ‘white spot’ and/or make the image much smaller (edit the size you want displayed)? the image takes up a bunch of real estate ..

just noodlin .. 

 

 

Userlevel 7
Badge +5

@john.desborough Ah! I see - thank you! If you don’t add an image there, it will default to the Typeform image you’re seeing in the screenshot. We don’t have a way to remove it, but I can note the suggestion. :) 

Userlevel 1

this thread is very informative for me who is new to Typeform. Thanks for all these leads. Perhaps a follow-up to this discussion. Were you able to integrate variables present in the link preview like "name=laura"?

For my part, the preview link does not take these variables into consideration. The disadvantage is that when the lead clicks on the image, he is not directed to his own form. Do you have any suggestions on this? @Liz 

Reply