Question

NSP is not looking nice when embedded into email

  • 19 November 2022
  • 5 replies
  • 58 views

My NPS is stacked on a few lines and the labels are not in the correct place. Does anyone know how to fix the NSP


5 replies

Userlevel 7
Badge +5

Hi @locationworks Could you send a screenshot of the issue and let us know which email service provider you’re using? 

Badge

I have the same problem. It doesn’t look nice when embedded.

If I look it in Outlook, it is like this:

And if I open the email in browser, it looks like this:

We are using ClickDimensions for our our newsletters.

Userlevel 7
Badge +5

Hi @Riinuska I’m afraid I’m not familiar with that email builder, but are you only experiencing the issue in Outlook? Outlook is known to restrict quite a bit of formatting in emails. 

Badge

Hi @Liz 

I haven’t of course checked all the possible email programmes, but in Outlook it looks really bad. Gmail was fine, but then in Samsung email app the number 5 was over the beige area, just like when opening the mail in browser. And what I find actually really clumsy is that when you click the number in your email, it opens up the same question again on browser and then you have to submit it for real. 

Userlevel 7
Badge +5

Hi @Riinuska Ah got it. If you notice this happening in other email services, let us know, but I do know Outlook doesn’t present customized styles well. 

As for needing to open in the browser, this is expected behavior. You can read more about how the email embed works here

Reply