Question

Some respondents unable to submit their responses.

  • 9 August 2021
  • 6 replies
  • 898 views

 

Some respondents are unable to submit their responses. The platform makes them respond all over again, like a loop. How to fix this? It has happened more often.


6 replies

Userlevel 7
Badge +5

Hi @Auani Happy Monday! Would you mind sharing more detail about this and the URL of your form? For example, are they experiencing an error? Is there a certain question they’re being looped back from? This will help us answer in more detail. :) 

Hi Liz, Sure. There is no specific question that slows down the progress of the research. Some respondents report that after answering some questions, they are unable to move forward, as if they had not answered the mandatory questions. They just answer (and that happens even with non-mandatory questions). I myself, filling out the questionnaire last Friday, experienced it myself. You fill in and can't go forward, every time you click it goes back to a question towards the beginning of the survey (I couldn't detect a pattern). After a while, out of nowhere, I tried again, and the submit button appeared, but it appeared at the end of one of the parts of the survey and not at the end of the entire questionnaire. More people have been reporting this same type of issue to me since Thursday. Some people reported problem with Safari, when switching to Chrome, they were able to move forward. But this happened to users of other browsers too. Finally, some respondents have had trouble uploading photos, although this is a minor issue. This is the SURVEY URL: https://fdozr4t26sp.typeform.com/to/M9YIQZ2Y THANKS FOR LISTENING AÛANI

Userlevel 7
Badge +5

Thank you, @Auani ! I tested the form, and I was able to submit it without any issues. Though, I did notice the form has quite a few questions, which can cause the form to slow down. If you haven’t already seen, I would suggest splitting the form into two and tying them together to see if this helps with the issues. Additionally, this would allow you to have the respondent submit answers along the way, too!

I saw the Typeform tab in the platform admin. In fact, the search is long. I didn't know about the possibility of splitting the survey, this is where you could recommend it through a button or prompt during the production of the surveys. Anyway, my research is in the final phase, I can't change it right now. Any other suggestions to minimize the risk of problems now? Browser suggestion? not upload the photo? thanks

Userlevel 7
Badge +5

Hi @Auani I can definitely share this suggestion with the product team! I’m afraid I don’t have any other suggestions offhand, as reducing the number of questions will greatly help the loading speed. Do you happen to have the form embedded on a website? If so, sometimes the embed itself can cause issues. If you do have it embedded and wouldn’t mind sending the URL over, I’m happy to take a look. 

Userlevel 7
Badge +5

Hey @Auani!

How are you getting on with this? Have you managed to improve the loading time? If not, you can share your URL and my friend @Liz can take a look at it! :slight_smile:

When the forms are very long, this can indeed affect loading times. 

Reply