Question

Hidden Fields not Displaying Results


Hi Team,

 

I’ve created a survey with a single hidden field (JobNo) so that we can track respondents. We’re seeking feedback on quoted jobs. I’m delivering the e-mail via MailChimp. The link works correctly and will provide each recipient a unique link depending on their job no.

 

In MailChimp I import the recipients and have created a custom field in there which contains the link from Typeform. All contacts have a name, email address and web link (to the typeform form). Example:

 

nh1tdtug777.typeform.com/to/[uniquesurveyno.]#jobno=2829960

 

The issue I’m having is only some responses are capturing the hidden field (about 50%). All the testing I completed prior to releasing live worked 100%. Each example of a completed survey resulted in the JobNo being captured in the results. I require all responses to retain the job number as we need to know who’s responded. I have checked all the contacts in Mailchimp to ensure the link was imported correctly and this is correct.

 

Please help!


10 replies

Userlevel 7
Badge +5

Hi @PTS Thanks for stopping by the community. It’s possible that the respondents are clicking on the link and then re-clicking on the link/editing the field info in the URL which would then remove the hidden field. This, I’m afraid, we can’t control. 

However, do you mind sharing a screenshot of how you have the link setup in the email? 

Thanks for the reply.

 

Hear what you’re saying as a possibility. I would be very surprised though if 50% of respondents were editing the link to remove the hidden field, though.

 

Inside MailChimp I have each contact with a unique link loaded. Example below. This field is then entered as the link within the ‘survey’ button on the e-mail itself.

 

 

Userlevel 7
Badge +5

Hi @PTS If they have cookie tracking turned off, this could also be causing the issue. Do you mind sharing what the URL is being inputted? From what I can see, it’s a merge field - is that adding the url with the values? 

Hi Liz,

 

Yes correct. The merged field in Mailchimp is simply embedding the link I’ve added per customer. The link is individual for each recipient based on the job number that was loaded in our own business system.

 

Cookies being turned off would be quite the roadblock for typeform hidden fields wouldn’t it? If that were the case I would almost expect everyone delivering survey links to recipients would run into the same issue where hidden field info wasn’t being populated when a survey was completed

 

To highlight the issue as well, here’s an image of the responses this morning. 2/3’s of the responses do not have the jobno field populated. This is going to really cause an issue for us 

 

Userlevel 7
Badge +5

Hi @PTS Could you share an example of one of those links? At the moment, I can’t quite see how those hidden fields are being passed in in the URL. 

Here’s an example of a link:

nh1tdtug777.typeform.com/to/pESz04PE#jobno=2823997

 

Userlevel 7
Badge +5

Thank you, @PTS ! It does look like the URL and settings in Typeform are set up correctly. The only other thing I can suggest at this point would be to contact Mailchimp to see if there’s anything on their side, specifically in the merge section, that would prevent the URLs from connecting correctly in that button. 

Userlevel 7
Badge +6

@Liz @PTS  - i would check on the device the users are using: as of  iOS 17 now there’s a new feature called Link Tracking Protection, which automatically removes tracking parameters from links that are clicked on in Mail, Messages. This means that email marketers who are using UTM tracking to track their iOS 17 traffic will no longer be able to see accurate data

 

not sure if this is pervasive across a lot other iOS versions (android guy over here) 

 

des

Userlevel 7
Badge +5

Oh! I didn’t know that - thanks for sharing, @john.desborough . It might be worth looking at your audience stats, @PTS , through the steps here to see how many of them are viewing your emails on an iOS device to help narrow down the issue, too. 

Thanks for the replies. I’ve just had a colleague do a test where I sent him a link and he’s completed on an iOS device and his laptop. Both examples came through with the JobNo hidden field

Reply