Error: Refused to Connect

  • 26 July 2021
  • 4 replies

I’ve been using an embedded from for about 3 years now. And then it stopped loading on the website.

On the website it will say “[my account name] refused to connect.”

I’m stymied on what the problem is because nothing really has changed. Here’s what I’ve tried.

  • In my Typeform account, I’ve confirmed that the form still works. I can go directly to it’s link and it loads perfectly
  • On my website hosting- and locally- I’ve tried re-copying the code snippet (the full page version). I’ve also tried other formatting like the Standard and Pop-Up options- but they do not work. 

I’ve confirmed that  my hosting looks fine- I can make other adjustments to the website and it works fine  content changes/color changes). And I’ve confirmed that the form is not broken on  Typeform. It seems like it’s the relationship between the two items? I’m not sure what else to try.



Best answer by john.desborough 26 July 2021, 15:38

View original

4 replies

Userlevel 7
Badge +6

@megansmith117 - this is from another user

is your site http:// or https://? there is a recent post about a change from a security perspective that requires https:// in order embedded typeforms to work. 


@Liz - sorry but i could not find the post, if you can link to it please.. 





Userlevel 7
Badge +6


here’s the link


@John perfect! That definitely explains the sudden change. Appreciate the link!

Userlevel 7
Badge +5

Thanks for the help, @john.desborough ! Let us know if you think of any other questions, @megansmith117 . :grin: