Google Sheets Not connecting with Typeform

  • 4 October 2021
  • 4 replies


When trying to connect my Google Sheet to Typeform it comes up with an error saying ‘Oops something went wrong’ but then I can see on my Google sheet it has created a new tab with the name of the Typeform.

Can anyone offer any help in getting the Typeform connected to the Sheet?



Best answer by Liz 4 October 2021, 16:34

View original

4 replies

Userlevel 7
Badge +5

Hi @InspiringCommunities Happy Monday! There are a few reasons why this may happen, the most common of those being that the name of the Google Sheet is the same name as your form. If this is the case, you’ll need to rename either the form or the Google Sheet and then try the connection again. 


Do you know if this might be the case for you? 

Hi Liz,

Thanks for your response! Yes I have tried renaming the sheet so that it is different to the form. This seems to remove the error message telling me to do that but then will still say ‘Oops Something went wrong’



Userlevel 7
Badge +5

Huh, that is odd. Have you tried with a totally new sheet/file, @InspiringCommunities ?

Userlevel 7
Badge +5

Hey @InspiringCommunities! I was wondering if you were able to connect your sheet to your typeform? Also, if you've followed @Liz's suggestion of trying with a totally new sheet/file? Let us know if you were able to fix this, and if yes, how you managed to do it! Wishing you a great day! :wink: