Feedback
Solved

My index.html doesn't display nothing

  • 17 November 2021
  • 4 replies
  • 31 views

Hello everyone! How are you?

Is my first time here and I’m not sure if this is the place to write my problem, so you just tell me where I should do and I’ll change it :grin:

I’m about to embed a typeform in a index.html file, and I just try some embed modes but none of them are working. I’m trying to create a webpage with just the typeform with nothing else, but the webpage doesn’t show me nothing, just a white screen. I will show you the code (just copied from the copy link)

 

<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>Document</title>
</head>
<body>
<div data-tf-widget="ql3AOvgY" data-tf-hide-headers style="width:100%;height:400px;"></div>
<script src="//embed.typeform.com/next/embed.js"></script>
</body>
</html>

 

And this is the error that the console displays:

 

 

Do you know how to fix it? Thanks for your time!

icon

Best answer by mathio 17 November 2021, 18:15

View original

4 replies

Userlevel 6
Badge +5

Hello @pako_shaman 

you are most likely opening the HTML file in your browser directly via file:// URL. You need to serve it via local server on your localhost, such http-server or express.js.

Thanks a lot @mathio !

Great! I did http-server and it works fine.

see you in the forums and nice to meet u!

Userlevel 6
Badge +5

Happy to help 😎

Userlevel 7
Badge +5

Hi @pako_shaman Glad @mathio ‘s solution worked for you! Also, I LOVE your profile pic! That frog’s expression is killing me. :rofl::joy:

Reply