Answered

Page jumps to typeform automatically but only in chrome

  • 8 February 2023
  • 4 replies
  • 154 views

I have used a standard html embed for a typeform. When the page load it jumps to my typeform however. But it only does this in google chrome as far as I can tell.

 

What I’ve found by googling:

  • I’ve disabled autofocus.
  • I’ve added “data-tf-disable-auto-focus”

Both didn’t work.

My embed code:
<div data-tf-widget="ijyVQSxq" data-tf-disable-auto-focus data-tf-opacity="100" data-tf-iframe-props="title=Contact Sherlock SEO Agency" data-tf-transitive-search-params data-tf-disable-scroll data-tf-auto-resize data-tf-medium="snippet" data-tf-hidden="name=,email=,hubspot_utk=,hubspot_page_name=,hubspot_page_url=" style="width:100%;height:500px;"></div><script src="//embed.typeform.com/next/embed.js"></script>

 

icon

Best answer by Sherlock SEO Agency 9 February 2023, 20:49

View original

4 replies

Userlevel 7
Badge +5

Hi @Sherlock SEO Agency Could you share the URL where you have the form embedded? Thanks!

I’m still bulding it so the website is unfinished. It’s is on the homepage above the footer.

https://staging.sherlockseo.com/

Weird part, I just checked the site to get the link. It isn’t doing it in chrome at the moment. So I checked edge, now it’s doing it there.

FOUND IT!

When the setting to remember previous answers is on and you have a multiple choice selected, it will always jump to the form. Remove your selection and the problem goes away.

Userlevel 7
Badge +5

Hi @Sherlock SEO Agency Glad to hear you were able to solve it, and thanks for sharing the solution! 😀

Reply