Answered

Problems with iOS device permissions

  • 9 November 2022
  • 4 replies
  • 664 views

We’ve tried several different iOS devices (iPad and iPhone) and every one is telling us that we haven’t enabled camera & microphone permissions. We are using the iframe method of embedding.

The error message that appears is:

“NotAllowedError - The request is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.

SAFARI - MAC- PERMISSION_DENIED_BROWSER_ERROR”

On one iPad (5th gen) I’ve set both camera and microphone to Allow rather than ask

I’ve tried on an Android phone (Moto g(8)power (Android 11) and that is opening the videoAsk website in a separate tab. I know this can be caused by the lack of valid SSL but SSL is present and on one of the test instances I know we have a completely valid certificate matching the domain perfectly.

icon

Best answer by andrew_videoask 10 November 2022, 14:22

View original

4 replies

Userlevel 7
Badge +5

Hi @Tim Smith, can you please share a link to the page where your videoask is embedded?

Feel free to message me the link privately if you’d like to keep it confidential. 

Userlevel 7
Badge +5

Thanks for sending over the examples, @Tim Smith!

You’ll want to copy and paste the exact code from the Share panel of your videoask.

Right now, you’re just embedding the videoask as a generic iframe. You want to embed it with camera, microphone and screen-sharing permissions as well.

Here’s the same code you’ll find in the Share panel (although you’ll want to add in your videoask URL).

<iframe src="https://www.videoask.com/XXXXXXXXXX"
allow="camera *; microphone *; autoplay *; encrypted-media *; fullscreen *; display-capture *;"
width="100%"
height="600px"
style="border: none; border-radius: 24px"
>
</iframe>

 

Thanks for getting back to me so quickly, I’ll pass that on to our web developers now

Userlevel 7
Badge +5

Happy to help, @Tim Smith!

Let me know if they have any further questions 🙂

Reply