Answered

Disable submissions for embedded forms

  • 7 November 2022
  • 9 replies
  • 263 views

How do I disable submissions for an embedded form? I’ve only found an example online for disabling using the share link: https://www.typeform.com/help/a/test-your-typeforms-without-creating-an-entry-for-advanced-users-360029295952/

 

My form is embedded and looks like:

<div data-tf-widget="MNCk637M" data-tf-iframe-props="title=Employee Engagement Survey (copy)" data-tf-medium="snippet" style="width:100%;height:400px;"></div><script src="//embed.typeform.com/next/embed.js"></script>

Is there a param I can add to disable submissions? I need debug an issue locally

 

icon

Best answer by mathio 8 November 2022, 12:41

View original

9 replies

Userlevel 7
Badge +5

Hi @nmoore Thanks for reaching out. I’m not quite sure I understand - are you looking to close the form to submissions completely? If so, this article here can walk you through closing your form to new entries. 

Hi @Liz. No, I don’t want to close the form to submissions. It needs to remain active on the site. There is an issue with formatting on the results page that I can only reproduce by completing the form. I’d rather not to send in a bunch of test submissions to debug this. I want to disable the form locally (prevent form submissions from my local environment) while I debug.

 

I’d like to have this feature → https://www.typeform.com/help/a/test-your-typeforms-without-creating-an-entry-for-advanced-users-360029295952/ but for embedded forms.

Userlevel 5
Badge +4

@mathio do you know if `?__dangerous-disable-submissions` is available in embed?

@nmoore alternatively I would suggest duplicating your for and running your tests on the duplicate so as to not mess up your metrics. 

 

Userlevel 7
Badge +5

@jvh you can use enableSandboxdata-tf-enable-sandbox in your embed to enable sandbox mode. It will disable both submissions and tracking.

Userlevel 1
Badge

Hi

I’m testing and using below 

https://4fgym3c496q.typeform.com/to/Wk8X8Z2S#convocatoria=2024&__dangerous-disable-submissions

And checking my plan, I have 99 left… so, its still enabled.

Im doing something wrong?

Thanks

Anna

 

Userlevel 7
Badge +5

Hello @annaestic 

you need to add the __dangerous-disable-submissions into URL query string, not hash. 

In your case the URL would look like this:

https://4fgym3c496q.typeform.com/to/Wk8X8Z2S?__dangerous-disable-submissions#convocatoria=2024

 

Userlevel 1
Badge

Ah ok !!!

I missundesrtood !

Thanks very much

Anna

Userlevel 7
Badge +5

Let us know how adding that in goes, @annaestic !

Userlevel 1
Badge

PErfect!!

That way works !!

Thanks

Anna

Reply