"Sorry you can’t access this typeform until the creator says so"



I’ve just put together my form of 7 questions. 

I then copied the link to my instagram bio but it doesn’t work.


I’m getting a message saying “Sorry you can’t access this typeform until the creator says so”

Is it something in settings that needs changing? I can’t find any setting options anywhere. 


Any help much appreciated! 





Best answer by john.desborough 17 March 2021, 13:52

View original

33 replies

Userlevel 1

I believe I have worked out why this is happening.


When you create a form, and proceed to Sharing, without first publishing, this error occurs. Unfortunately, i’ve not found a way to fix, once you have gone to sharing first. 


Only solve is to delete the form and start again. 



OK, Thanks.

And: This is what obviously triggered the bug in my case. I proceeded to the share unpublished.

Good to know: Publish first. Then share.




You’re Welcome. 


Userlevel 7
Badge +5

Hi @Discopjot Definitely reach out to our support team here, as they can log into your account and see what’s happening with the form. 

Userlevel 2

Hey @Discopjot @SaaSMouth - I’m the product manager working on this area and doing some digging.

I’m struggling to replicate the error here, even when I share and embed before publishing. Is this something you’re still running into?


Thanks, Dan

The problem isn’t with share and embed before publishing.

The problem is with embedding a duplicated form:


I tested on our platform which was built on Node.js & Next.js - maybe it’s a technical issue.

Userlevel 2

Hey @MaxPodhash - have you got any more details to share? I’ve also been testing embedding a duplicated form and can’t see any reason you’d be running into a problem.


I can’t see why your tech stack would interfere w/ a duplicate form being embedded.

I recently started using Typeform to create a survey. After obtaining the embed link, I tried to post it on Squarespace but received the error message that this thread is about. Upon reading this thread, I discovered that publishing the form was necessary, which I promptly did. However, the error persisted. To resolve the issue, I deleted the original form, created a new one, published it first, and then embedded it. Fortunately, this approach worked perfectly.

Thank you @SaaSMouth !

Userlevel 7
Badge +5

Happy to hear that worked, @Konrandah ! Thanks for letting us know. 😀