"Sorry you can’t access this typeform until the creator says so"



I’ve just put together my form of 7 questions. 

I then copied the link to my instagram bio but it doesn’t work.


I’m getting a message saying “Sorry you can’t access this typeform until the creator says so”

Is it something in settings that needs changing? I can’t find any setting options anywhere. 


Any help much appreciated! 





Best answer by john.desborough 17 March 2021, 13:52

View original

33 replies

Userlevel 7
Badge +6

@BenG - have you “published” the typeform? You need to do that before it can be seen by anyone. 



Thanks John that’s sorted it! As easy as that haha cheers 

Userlevel 7
Badge +6

Thanks John that’s sorted it! As easy as that haha cheers 

no worries.. it’s nice when something can be fixed that easily. 


Badge +5

Hey @BenG it’s great you managed to get this sorted. And @john.desborough thanks again for lending Ben a helping hand!

Just posting here to say that I’ve edited the thread title so it accurately represents the issue you described. You are not the only one who missed this little trick, this happens to lots of people so by using this title we may help others find this ‘little trick’ more easily. 

Great thanks! Glad I’m not the only one haha ; ) 

Badge +5

You are not alone, Ben :laughing:

I have just published my typeform but sharing its link on linkedin it doesn’t appear my customized layout other than there is the message ““Sorry you can’t access this typeform until the creator says so”. What could be the problem? I’ve got my professional suscription in place!

1000 thanks for helping!


Userlevel 7
Badge +5

Hi @cmarfil ! If you haven’t already, you’ll first want to update the meta settings in your form like so: 



Then, you can update how this appears using the LinkedIn Post Inspector below:


Let me know if this doesn’t work!



I did the little trick but it keeps saying the same thing for anyone trying to access the link.

I use the free version.


Userlevel 7
Badge +5

Hi @CharlotteCG What steps did you take to refresh the data? That’ll help us understand what else you may need to do. 😀



I’m getting a message saying “Sorry you can’t access this typeform until the creator says so”

Form has been published already. Did refresh, logout and logged back in, still the same.

Any help please?




Userlevel 7
Badge +5

Hi @Nate_69 Is the form turned to open for the public? (In case it had been switched off)

i am getting this issue as well. See refer a friend button in upper right -


The form is published and the form is open to responses. The other typeform on the page is working just fine.

seems to be very buggy with the new contact form option. when i duplicated it, that’s when it broke the first time. The second break happened when I simply made design adjustments to the embed...

Same problem here. Mght as well go find another quiz site cuz i wasted way too much time getting sucked in THEN being told about paid features THEN it won’t let anyone see it


Userlevel 7
Badge +5

Hi @LoriAnn Were you able to remove the paid features to be able to publish your form? Or are you still seeing that message? 

I’m getting this error too, when I embed. Embedded Typeforms from a few months ago are fine but anything recently throws the error. I can confirm the Typeform has been published and is open to new responses. Thanks community :)
Any ideas?

UPDATE: It looks like its the duplicate function thats broken things. Forms that are created from scratch are fine but anything that has been duplicated throws the error. Is there a way tot fix this?

Userlevel 7
Badge +5

Hi @amygorgias Huh, that sounds like it might be an issue with the account itself, as the duplication feature shouldn’t cause that error. Our support team can look closer into this by contacting them from your account email here

Thanks @Liz, ticket submitted. We’ll see how we go :)

Userlevel 7
Badge +5

Let us know what they say, @amygorgias !

When I tested embedding with a new form, it works properly.

When I tested embedding with a duplicated form, I have the same error.

So, you have the bug with duplicating forms.

Userlevel 7
Badge +5

Hm, that’s odd. Did the support team specifically say there is a bug with duplicated forms? This would be good to know if it’s widespread!

You can test it on your own 💁

Userlevel 1


Typeform is published, open and embedded like always. Typeform created from scratch, not duplicated.

It’s also random. Sometimes it loads, but then “flickers” back to the error message. Same behavior, when previewed in the actual Typeform application.

This is new and very of course: annoying.



I believe I have worked out why this is happening.


When you create a form, and proceed to Sharing, without first publishing, this error occurs. Unfortunately, i’ve not found a way to fix, once you have gone to sharing first. 


Only solve is to delete the form and start again.