Feedback
Answered

Facebook Pixel Domain Verification



Show first post

145 replies

Userlevel 3

Great news! Unfortunately I’m not able to verify my domein. 

I’m only able to verify tmo-fbs.typeform.com. But, in order to use the conversions I need to verify typeform.com. 

What am I missing?
 

 

Userlevel 2

Hi @Thijmen !

 

Did you try following the steps in our guide? As this part is explained over here.

Please let us know if the guide does not match what you are experiencing.

 
Userlevel 3

Hi @Thijmen !

 

Did you try following the steps in our guide? As this part is explained over here.

Please let us know if the guide does not match what you are experiencing.

 

Yes I did. Unfortunately not able to verify typeform.com. I keep getting an error in Facebook > Brand Safety > domains 

Userlevel 2

Could you share a screenshot of the error?

Userlevel 3

Could you share a screenshot of the error?

 

Userlevel 2

Hi @Thijmen 

 

So, I’ve double checked with my team, and there should be no need to verify typeform.com for conversions to work.

 

I can see that you’ve already verified tmo-fbs.typeform.com , which should be enough.

 

If you have found any documentation that says you need to also verify typeform.com, I’d appreciate it if you can link it.

 

 
Userlevel 3

Okay thanks. The domain looks verified but I’m still not able to use the conversion event to optimize and see results in Facebook. 

I get the following warning:

 

If I go to my pixel and go to Web Event Configurations to rank my events (maximum of 8) I’m not able to select the (custom) events because I can only select typeform.com instead of tmo-fbs.typeform.com.

See screenshot below:

 

The problem might be that we are only able to verify our subdomain instead of the domain itself typeform.com. I won’t be the first client who are having this problem I’m afraid. 

Are there any other Facebook experts having this problem? 

Userlevel 2

Thank you @Thijmen 

@Gabriel , is there any chance we can link @Thijmen with one of our CS representatives to have an engineer look into this issue?

Let’s find out if we need to change something on our end, or if there’s something we’re just missing in our documentation.

Badge +5

Thank you @Thijmen 

@Gabriel , is there any chance we can link @Thijmen with one of our CS representatives to have an engineer look into this issue?

Let’s find out if we need to change something on our end, or if there’s something we’re just missing in our documentation.

 

I've done that already. Someone should get in touch with Thijmen via email 👍

Userlevel 2

Getting the same problem. Have managed to verify the sub domain within the Facebook > Brand Safety > domains setting, but this domain ISNT showing up under the new Web events configuration area for verified domains. This seems to be the same for Thijmen above. 

Look forward to any updates. @Gabriel  

I’m a consultant for the account, so if you need my email let me know. 
Should also add that I wasn’t able to add the sub domain in the way described in your new instruction sheet. It was trial and error, but events still not showing up. 

Badge +5

Getting the same problem. Have managed to verify the sub domain within the Facebook > Brand Safety > domains setting, but this domain ISNT showing up under the new Web events configuration area for verified domains. This seems to be the same for Thijmen above. 

Look forward to any updates. @Gabriel  

I’m a consultant for the account, so if you need my email let me know. 
Should also add that I wasn’t able to add the sub domain in the way described in your new instruction sheet. It was trial and error, but events still not showing up. 

 

Hi @Jvadams , welcome! I can share your case with our team as they would like to investigate further. Just please confirm you are an admin of the account/typeform you are trying to verify so the team can make the connection between your email and the typeform in question. 

 

Userlevel 2

Getting the same problem. Have managed to verify the sub domain within the Facebook > Brand Safety > domains setting, but this domain ISNT showing up under the new Web events configuration area for verified domains. This seems to be the same for Thijmen above. 

Look forward to any updates. @Gabriel  

I’m a consultant for the account, so if you need my email let me know. 
Should also add that I wasn’t able to add the sub domain in the way described in your new instruction sheet. It was trial and error, but events still not showing up. 

 

Hi @Jvadams , welcome! I can share your case with our team as they would like to investigate further. Just please confirm you are an admin of the account/typeform you are trying to verify so the team can make the connection between your email and the typeform in question. 

 

Hi @Gabriel I am using the admin access to the account, but I am not the email address on the account. However, I did have a live chat with your customer support team on 18 Feb 2021, 09:05 AM (GMT+0) in which I gave my email address and name. I’m more than happy for your team to contact me so that I can supply screenshots or even live chat/video chat, if that would help. I’m very keen to get this problem resolved as soon as possible as we have a Facebook campaign going live any day now for this charity client (and I have several other charity accounts with FB ad campaigns going live in the next week/month that requite the Typeform integration in order to succeed). Thank you. Jane

Badge +5

Thanks for that info @Jvadams , as long as you shared the necessary information to verify you as the account owner, it should be fine. Did you pass on that information to the chat team? Do you know if they opened a case for you? 

Userlevel 2

Thanks for that info @Jvadams , as long as you confirmed the email address on the account it should be fine. Did you pass on that information to the chat team? Do you know if they opened a case for you? 

 

As far as I know they didn’t open a case - as at that point I was asking for advice on the new procedure and they said it would be complete by Friday and they would send me the user notes. They didn’t. I found the user notes in this feed. I didn’t realise until following the notes that there was a problem in the setup - and that it wasn’t working. 

However, I did login to the live chat using the client account, and confirmed my name and email address within the chat. I’m happy to email a transcript of this chat to you @Gabriel if you’d like to give me an email address? Alternatively, feel free to email me (I’m presuming you should be able to see my email address which starts janevadams@ ) Thanks. Jane 

Badge +5

Hi @Jvadams, let me send you a DM, if we have the account holder information things may be quicker. 

Userlevel 2

Hi @Jvadams, let me send you a DM, if we have the account holder information things may be quicker. 

DM’d you. Thanks. Jane 

Hello,

I have the same issue like @Thijmen. Is there any solutions for that?

Thank you very much.

Badge +5

Hello,

I have the same issue like @Thijmen. Is there any solutions for that?

Thank you very much.

 

Hi there @phil2gold, thanks for popping by the community. Have you been in contact with our support team at all? We are already investigating this matter, but in this particular case I recommend you get in touch with them. Let me know if you need help with that. 

Hi @Stefan and @Gabriel thanks for working on this problem. I need help doing this with my typeform and i am not allowed access to the link @Stefan provided. Would appreciate some assistance asap because my FB ads are currently collapsing due to the ios update. Thanks!

Userlevel 7
Badge +5

Hey @tomm

 

Thanks for sharing this with us! Can you please contact the support team here? We'll have an engineer looking into your case. 

 

Also, please make sure you use the email of your Typeform account as non-typeform users get a different priority. =)

Hi, we have exactly the same problem here!

Badge +5

Hi everyone, 

sorry about the silence within the last couple of days. I want to share an update based on some internal research we are conducting. 

 

As you already know, as soon as Apple releases their iOS14 privacy policy update, domains will have to be verified to adapt to the new way Facebook will track ads and reports with aggregated events. This means that your reporting might be impacted -  click here to learn how. 

 

After investigating this changes we decided to implement a feature where you can verify the subdomain you use at Typeform, but after testing and re-assessment Facebook documentation we discovered that this is not enough: 

 

7nD4Cb7E97tvHltqnYF0SkXAoa4LLqdDAjgGUa6oFH-PbijovROwk_O4SODLqW-nNsnbQw3egXL_4udbeVYu0po3hTHh3D7gjnXXiYUB3KbLM6tKQKb9KlA59uCGqCnMScU72J7t

 

We continue working on this with high priority but it looks like the fix depends on Facebook - the reason being that their implementation hasn’t taken into account the needs of those with 3rd party domains. This is briefly covered in this blog post (please scroll down to “The Problem: You Don’t Own the Domain”)

 

We are going to contact Facebook directly because we believe this change leaves out everyone using third party domains like yourselves. We do encourage you to flag it to them too, the more buzz around this issue the more chances they will act quickly on it.  

 

So how is this impacting you?

It’s important to note that Apple hasn’t released these privacy changes impacting iOS14 yet. The changes are expected to be released sometime next spring. We run a couple of tests with customers and confirmed that you should still be able to set up your ads even though you will get a warning like this one: 

 

VsVUIzDSHd9fCRbhpmHjYqibbObWirJmsAwdmfdvQwv1zeIQ7ZyGFB3IdKocF3xF35_5Tnj7dkC5zKxKCekpfAOWI443Urc2lJWz_z_iWjiw5Usu1WUqDXyz0TEr2GZUdhm_iEXm

 

Continue with the setup and ignore these messages, those are just a warning from Facebook and not currently enforced. 

 

However, if you still have issues and can’t set up your campaigns contact our support team through this page. Try and describe all the steps with as much detail as you can so we can understand where you are getting stuck and see if there’s a solution for your particular use case.

 

If you can record a video that would be even better, you can use Loom (which is free!) or, if you are a Mac user, QuickTime.  

 

Thanks everyone for the information provided in this thread. You are helping us get a full picture of this issue and its impact to everyone using Typeform and Pixel. 

 

We’ll bring more news whenever we make some meaningful progress.  

 

Thanks to @Nordin for his help with all this information. 

Hi, I’m trying to access the content of that link, but it seems to point nowhere. Can you help?

Is there anything, in particular, I need to do on my end?

 

Hey community!

 

Thank you so much for your patience on this, and your interest.

 

I'm writing to you on behalf of Engineering @ Typeform :slight_smile:

 

The good news is that we now fully support verification via URL flow for Facebook pixel.  More info here on how to use it.

 

 

 

Badge +5

Hi, I’m trying to access the content of that link, but it seems to point nowhere. Can you help?

Is there anything, in particular, I need to do on my end?

 

Hey community!

 

Thank you so much for your patience on this, and your interest.

 

I'm writing to you on behalf of Engineering @ Typeform :slight_smile:

 

The good news is that we now fully support verification via URL flow for Facebook pixel.  More info here on how to use it.

 

 

 

That was a link to an article on our Help Center but it seems it's been talking down because it takes you through the steps of verifying your Typeform subdomain, which isn't what Facebook wants. 

I'll check with @Nordin and @Jon tomorrow to understand what the plans are to update this content. 

I don't think there's anything for you to do at the moment. Are you still trying to set up and track your campaigns using Typeform on Pixel? 

Thanks for participating in the discussion by the way. 

I already did, but I’m still being asked to verify typeform domain

Reply